Welcome to the Twincam Club Forum!

For the Toyota Enthusiast.

Experiencing a problem with your car? Troubleshoot in here.
By Kimmo
#810793
Hi Guys

My twincam with dicktator is not starting. The red light is on, the green light flashes when car is swinging and the faint light( like yellowish) can be seen when swinging. The relay for the coil and fuel pump is clicking. There is fuel going to the rail and there's power to the injectors.
As for spark there is but its bluish.
I don't know what to check for now.

The cars been parked off for a while, say about 3 months or so.

Any help will be appreciated.
By Deeno
#810797
If ur prepared to, remove fuel rail crank and have someone check injectors are actually pulsing/spraying fuel. You can try spraying quickstart into intake and if motor "takes" then you know its a fuelling prob. That's fuel sorted.

Compression. Check timings spot on cambelt and dizzy rotor is turning.

Spark: check rotor, dizzy cap, coil leads. Change plugs. Swop coolant temp sensor. Check ground especially for coil.

Pm Lowrsi, resident Dicktator fundi of note
By LowRSI
#810799
when you say relay is clicking, do you mean its clicking when swinging motor?, or just clicks once on?

can you hear fuel pump priming?

if someone switches on ignition for you, can you hear fuel passing through the fpr?

most times when standing long time, its the relay, change the dicktator relay.

another ting to keep in mind, if no voltage compensation is set up, or set badly, it will struggle to start.

hook up another car to boost battery, make sure the jumper cables are connected positive to positive, and negative to supply bat to engine block of car you want to start.

change spark plugs, sometimes when it stood for long time, the plugs get fouled by initial priming of injectors,

also check water temp sensor for management is connected, no not the one for dash. the two pin one, usually green.
By Kimmo
#810809
LowRSI wrote:when you say relay is clicking, do you mean its clicking when swinging motor?, or just clicks once on?

can you hear fuel pump priming?

if someone switches on ignition for you, can you hear fuel passing through the fpr?

most times when standing long time, its the relay, change the dicktator relay.

another ting to keep in mind, if no voltage compensation is set up, or set badly, it will struggle to start.

hook up another car to boost battery, make sure the jumper cables are connected positive to positive, and negative to supply bat to engine block of car you want to start.

change spark plugs, sometimes when it stood for long time, the plugs get fouled by initial priming of injectors,

also check water temp sensor for management is connected, no not the one for dash. the two pin one, usually green.
Hi Low

The relay clicks when I turn the key on.

Fuel pump is priming. Didn't check if fuel is passing through the fuel pressure regulator.

I'm using a fully charged battery.

I changed the injectors to see if it will start and it didn't.

Also didn't change the plugs. Will change them today.

The green plug by the thermostat housing? If that's the water temp sensor then its connected.
By JWilliams
#864907
Hi all,
I have rebuild a STD 4age twincam motor, we are using a Dicktator Wasted spark with 60-2 trigger wheel,corsa coil pack. We did setup the timeing, Car did not want to start.. :roll:

Any :dontknow: trigger position
Motor Backfires
New plugs fitted all fire, has spark

Tx
#864908
Guys i need help with my toyota 20v.

The car didnt want to start i had to push the car to get it to start then i took out the battery used a other battery and it started i then bought a battery and it did not want to start i then tried the battery in another car and it doesnt start.

I thenngot a other battery and tested in another car and it starts but when i put it in my car it has a slow start but nothing happens i changed the battery terminals, i added a relay on the starter and nothing happens i checked all grounds and everything its all right...

I dno what it could be as i changed the starter selinoid aswell and it drove before but the issues arised on a faulty battery and after changing it it doesnt want to start.
Conquest Clips

Hi Guys, I am looking for the clips for the rear[…]